您的位置:首页 > 其它

zoj 2417 Lowest Bit

2009-05-10 19:10 369 查看
ZOJ Problem Set - 2417

Lowest Bit

Time Limit: 1 Second Memory Limit: 32768 KB

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output

For each A in the input, output a line containing only its lowest bit.

Sample Input

26

88

0



Sample Output


2

8

Author: SHI, Xiaohan

Source: Zhejiang University Local Contest 2005

Submit Status

#include<iostream>

#include <cmath>

using namespace std;

int main()

{

int n , h;

while (cin >> n)

{

if (n == 0)

break;

int j = 0;

while (n % 2 == 0)

{

n /= 2;

j ++;

}

h = pow (2.0 , j);

cout << h << endl;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: