您的位置:首页 > 其它

pku_1159 Palindrome

2009-02-06 18:39 453 查看
题目连接:http://acm.pku.edu.cn/JudgeOnline/problem?id=1159
Palindrome

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 20403Accepted: 6847
Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd

Sample Output
2

KEY:这道题是典型的DP,状态转移方程,如下:
if(s[i]==s[j]) dp[i][j]=dp[i+1][j-1];
else dp[i][j]=MIN(dp[i+1][j],dp[i][j-1])+1;
如果数组用int类型,那么会出现MLE的情况,所以用short混过去...

C++代码:
#include<iostream>
#include<string>
#define N 5000
using namespace std;
int n;
string s;
short dp[N+1][N+1];
int MIN(int x,int y)
{
if(x>y) return y;
else return x;
}
void DP()
{
int i,j;
for(i=n-1;i >= 0;i--)
for(j=i+1;j <= n;j++)
if(s[i]==s[j]) dp[i][j]=dp[i+1][j-1];
else dp[i][j]=MIN(dp[i+1][j],dp[i][j-1])+1;
}
int main()
{
//	freopen("pku_1159.in","r",stdin);
while(cin>>n)
{
cin>>s;
memset(dp,0,sizeof(dp));
DP();
cout<<dp[0][n-1]<<endl;
}
return 1;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: