您的位置:首页 > 其它

FOJ 1543 Avoid The Lakes

2008-08-08 11:20 357 查看
Avoid The Lakes

Time Limit:1sMemory limit:32M
Accepted Submit:46Total Submit:60
Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.
The farm is represented as a rectangular grid with N (1<=N<=100) rows and M (1<=M<=100) columns. Each cell in the grid is either dry or submerged, and exactly K (1<=K<=N*M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.
Input:
The input will consist of several datasets.
Each dataset contains two parts:
*Line 1: Three space-separated integers: N, M, and K.
*Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C.
Input is terminated by end of file.
Output:
For each dataset,you should output the number of cells that the largest lake contains.
Sample Input:
3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output:
4
Hint
Input Details:
The farm is a grid with three rows and four columns; five of the cells are submerged. They are located in the positions (row 3, column 2); (row 2, column 2); (row 3, column 1); (row 2, column 3); (row 1, column 1):
# . . .
. # # .
# # . .

Original: USACO 2007 November
题目就是求最大的'#'的面积...

深搜,当时入门的时候做的题,怀念(又来了~~~~~~~~~~~~~-________________-)

#include <stdio.h>

#include <string.h>

int grap[100][100],n,m,max_area=1,area;

void find_max_area(int x,int y)

{

if(y-1>=0&&grap[x][y-1]==1){area++;grap[x][y-1]=0;find_max_area(x,y-1);}

if(y+1<m&&grap[x][y+1]==1){area++;grap[x][y+1]=0;find_max_area(x,y+1);}

if(x-1>=0&&grap[x-1][y]==1){area++;grap[x-1][y]=0;find_max_area(x-1,y);}

if(x+1<n&&grap[x+1][y]==1){area++;grap[x+1][y]=0;find_max_area(x+1,y);}

}

int main()

{int i,j,ls;

//freopen("D://in.txt","r",stdin);

while(scanf("%d%d%d",&n,&m,&ls)!=EOF)

{ max_area=1;

area=1;

memset(grap,0,sizeof(grap));

while(ls--)

{scanf("%d%d",&i,&j);

grap[i-1][j-1]=1;}

for(i=0;i<n;i++)

for(j=0;j<m;j++)

if(grap[i][j]==1)

{grap[i][j]=0;area=1;find_max_area(i,j);max_area=max_area>area?max_area:area;}

printf("%d/n",max_area);

max_area=1;

area=1;

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: