您的位置:首页 > 其它

fjnu 1250 Beat the Spread!

2008-02-16 14:17 417 查看
Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.
Given the winning numbers for each type of bet, can you deduce the final scores?

Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.

Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.

Sample Input

2
40 20
20 40


Sample Output

30 10
impossible


KEY:题目看懂了没什么难的;


Source:




#include<iostream>


using namespace std;




int a,b;


int n;




void fun()




...{


int t1,t2;


if(a<b||(a+b)%2)


cout<<"impossible"<<endl;


else




...{


t1=(a+b)/2;


t2=(a-b)/2;


cout<<t1<<" "<<t2<<endl;


}




}




int main()




...{


cin>>n;


for(int i=1;i<=n;i++)




...{


cin>>a>>b;


fun();


}


}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: