您的位置:首页 > 其它

acm hnu 10038 进制转换

2006-10-23 11:40 387 查看
Lowest Bit
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 257, Accepted users: 238
Problem 10038 : No special judgement
Problem description
Given an positive integer A (1 <= A <= 10^9), output the lowest bit of A. For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2. Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

Input
Each line of input contains only an integer A (1 <= A <= 109). A line containing "0" indicates the end of input, and this line is not a part of the input data.

Output
For each A in the input, output a line containing only its lowest bit.

Sample Input
26
8
0

Sample Output
2
8

Problem Source
HNU 1'st Contest
#include <stdio.h>
#include <math.h>

int getbits(int);
main()
{
int n;
scanf("%d",&n);
while(n!=0){
printf("%.0f ",pow(2,getbits(n)));
scanf("%d",&n);
}

return 0;
}

int getbits(int n)
{
if(n==1)return 0;
int tmp=n,i=0,s[100];
for (i = 0;i<100;i++)s[i]=-1;
i = 0;
while(1){
if( (s[i++]=tmp%2) == 1)return i-1;
tmp = tmp/2;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: