您的位置:首页 > 其它

ZOJ-1006-Do the Untwist

2006-05-12 02:29 197 查看
这道题没什么好说的,非常简单,虽然是密码相关,但是给出了翔实的背景和过程,唯一需要动一点脑的地方就是从题目中公式里求余的结果得到原数。

由于懒得再写一个和这个程序相反的加密程序,所以只用了sample数据试了一下,一看没错,就提交了,这回一次就AC了,不过我发现我的程序用的memory都在800多k,也不知道那些只用了300或400k的人是怎么弄的。

Do the UntwistTime limit: 1 Seconds Memory limit: 32768K
Total Submit: 2012 Accepted Submit: 999
Cryptography deals with methods of secret communication that transform a message (the plaintext) into a disguised form (the ciphertext) so that no one seeing the ciphertext will be able to figure out the plaintext except the intended recipient. Transforming the plaintext to the ciphertext is encryption; transforming the ciphertext to the plaintext is decryption. Twisting is a simple encryption method that requires that the sender and recipient both agree on a secret key k, which is a positive integer.

The twisting method uses four arrays: plaintext and ciphertext are arrays of characters, and plaincode and ciphercode are arrays of integers. All arrays are of length n, where n is the length of the message to be encrypted. Arrays are origin zero, so the elements are numbered from 0 to n - 1. For this problem all messages will contain only lowercase letters, the period, and the underscore (representing a space).

The message to be encrypted is stored in plaintext. Given a key k, the encryption method works as follows. First convert the letters in plaintext to integer codes in plaincode according to the following rule: '_' = 0, 'a' = 1, 'b' = 2, ..., 'z' = 26, and '.' = 27. Next, convert each code in plaincode to an encrypted code in ciphercode according to the following formula: for all i from 0 to n - 1,

ciphercode[i] = (plaincode[ki mod n] - i) mod 28.
(Here x mod y is the positive remainder when x is divided by y. For example, 3 mod 7 = 3, 22 mod 8 = 6, and -1 mod 28 = 27. You can use the C '%' operator or Pascal 'mod' operator to compute this as long as you add y if the result is negative.) Finally, convert the codes in ciphercode back to letters in ciphertext according to the rule listed above. The final twisted message is in ciphertext. Twisting the message cat using the key 5 yields the following:

Array012
plaintext'c''a''t'
plaincode3120
ciphercode31927
ciphertext'c''s''.'
Your task is to write a program that can untwist messages, i.e., convert the ciphertext back to the original plaintext given the key k. For example, given the key 5 and ciphertext 'cs.', your program must output the plaintext 'cat'.

The input file contains one or more test cases, followed by a line containing only the number 0 that signals the end of the file. Each test case is on a line by itself and consists of the key k, a space, and then a twisted message containing at least one and at most 70 characters. The key k will be a positive integer not greater than 300. For each test case, output the untwisted message on a line by itself.

Note: you can assume that untwisting a message always yields a unique result. (For those of you with some knowledge of basic number theory or abstract algebra, this will be the case provided that the greatest common divisor of the key k and length n is 1, which it will be for all test cases.)

Example input:

5 cs.
101 thqqxw.lui.qswer
3 b_ylxmhzjsys.virpbkr
0

Example output:

cat
this_is_a_secret
beware._dogs_barking

Problem Source: Zhejiang University Local Contest 2001
#include <iostream>
using namespace std;
char pt[71],ct[71];//plaintext,ciphertext
int pc[71],cc[71],key,n;//plaincode,ciphercode,key,n;

void ct2cc()//密文TO密码
{
int i;
for(i=0;i<n;i++)
{
if('_'==ct[i])
{
cc[i]=0;
}
else if('.'==ct[i])
{
cc[i]=27;
}
else
{
cc[i]=int(ct[i])-96;
}
}
return;
}

void cc2pc()//密码TO平码
{
int temp=0,i,count;
for(i=0;i<n;i++)
{
count=0;
temp=(cc[i]+28*count)+i;
while(!(temp>=0 && temp<=27))
{
if(temp>27)
{
count--;
}
else if(temp<0)
{
count++;
}
temp=(cc[i]+28*count)+i;
}
pc[(key*i)%n]=temp;
}
return;
}

void pc2pt()//平码TO平文
{
int i;
for(i=0;i<n;i++)
{
if(0==pc[i])
{
pt[i]='_';
}
else if(27==pc[i])
{
pt[i]='.';
}
else
{
pt[i]=char(pc[i]+96);
}
}
return;
}

int main()
{
int i;
while(cin>>key)
{
if(key==0) break;
cin>>ct;
n=strlen(ct);
ct2cc();
cc2pc();
pc2pt();
for(i=0;i<n;i++)
cout<<pt[i];
cout<<endl;
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: